0%

Rating_os 4.5
Rating_num 2748
Requirements Microsoft® Windows® Vista (Service Pack 2) or Windows® 7 or Windows® 8. Windows® XP is NOT supported.
Release date Oct 31, 2013